Table of contents
Topics on this page

Linux systemd support

Some agent versions support systemd for Linux. 

Indicators:
✔ — Supported. If support was added in an update, then the minimum required version is indicated in the footnote.
• — Support for these releases is ending soon. Please upgrade as soon as possible.

Operating System Agent Version
20 LTS 12 FR 12 LTS 11 LTS
AlmaLinux 8 (64-bit) ✔ 9
AlmaLinux 9 (64-bit) ✔ 16
Amazon Linux 2 (64-bit)
Amazon Linux 2 (AWS ARM-Based Graviton 2) 8
Amazon Linux 2 (AWS ARM-Based Graviton 3) 12
Amazon Linux 2023 (64-bit) 17
Amazon Linux 2023 (AWS ARM-Based Graviton 2) 17
CloudLinux 8 (64-bit) ✔ 5
Debian Linux 10 (64-bit) ✔ 3 ✔ 4
Debian Linux 11 (64-bit) ✔ 10
Debian Linux 12 (64-bit) ✔ 21
Miracle Linux 8 (64-bit) ✔ 18
Miracle Linux 9 (64-bit) ✔ 20
Oracle Linux 7 (64-bit) ✔ 3 ✔ 2
Oracle Linux 8 (64-bit) ✔ 6 ✔ 4
Oracle Linux 9 (64-bit) 15
Red Hat Enterprise Linux 7 (64-bit) ✔ 3 ✔ 2
Red Hat Enterprise Linux 8 (64-bit) ✔ 1
Red Hat Enterprise Linux 8 (AWS ARM-Based Graviton 2) ✔ 10
Red Hat Enterprise Linux 8.6 (PowerPC little-endian) ✔ 19
Red Hat Enterprise Linux 9 (64-bit) ✔ 12
Rocky Linux 8 (64-bit) ✔ 9
Rocky Linux 9 (64-bit) ✔ 14
SUSE Linux Enterprise Server 12 (PowerPC little-endian) ✔ 22
SUSE Linux Enterprise Server 15 (64-bit) 2
SUSE Linux Enterprise Server 15 (PowerPC little-endian) ✔ 22
Ubuntu 18.04 (64-bit)
Ubuntu 18.04 (AWS ARM-Based Graviton 2) 9
Ubuntu 20.04 (64-bit)
Ubuntu 20.04 (AWS ARM-Based Graviton 2) ✔ 9
Ubuntu 22.04 (64-bit) ✔ 11
Ubuntu 22.04 (AWS ARM-Based Graviton 2) ✔ 13

Footnotes:

  1. 

    Requires Deep Security Agent 11.0.0-796 U12 (2019-06-22) or later.

  2. 

    Requires Deep Security Agent 11.0.0-871 U13 (2019-07-26) or later.

  3. 

    Requires Deep Security Agent 12.0.0-481 U1 (2019-08-09) or later.

  4. 

    Requires Deep Security Agent 11.0.0-946 U14 (2019-08-29) or later.

  5. 

    Requires Deep Security Agent 12.5.0-936 FR (2020-05-19) or later.

  6. 

    Requires Deep Security Agent 12.0.0-563 U2 (2019-09-13) or later.

  7. 

    Requires Deep Security Agent 20.0.0-3165 (20 LTS Update 2021-10-08) or later.

  8. 

    Requires Deep Security Agent 20.0.0-1822 (20 LTS Update 2021-01-18) or later.

  9. 

    Requires Deep Security Agent 20.0.0-3288 (20 LTS Update 2021-10-28) or later.

  10. 

    Requires Deep Security Agent 20.0.0-3964 (20 LTS Update 2022-03-01) or later.

  11. 

    Requires Deep Security Agent 20.0.0-4959 (20 LTS Update 2021-07-04) or later for Windows, and 20.0.0-158 (20 LTS Update 2022-07-11) or later for macOS.

  12. 

    Requires Deep Security Agent 20.0.0-5137 (20 LTS Update 2022-07-26) or later.

  13. 

    Requires Deep Security Agent 20.0.0-5394 (20 LTS Update 2022-08-29) or later.

  14. 

    Requires Deep Security Agent 20.0.0-6313 (20 LTS Update 2023-01-31) or later.

  15. 

    Requires Deep Security Agent 20.0.0-6658 (20 LTS Update 2023-03-22) or later.

  16. 

    Requires Deep Security Agent 20.0.0-6912 (20 LTS Update 2023-05-02) or later.

  17. 

    Requires Deep Security Agent 20.0.0-7303 (20 LTS Update 2023-06-28) or later.

  18. 

    Miracle Linux 8 is supported by Deep Security Agent 20.0.0-7719 (20 LTS Update 2023-08-29) or later for Red Hat Enterprise Linux 8.

  19. 

    Requires Deep Security Agent 20.0.0-7943 (20 LTS Update 2023-09-26) or later.

  20. 

    Miracle Linux 9 is supported by Deep Security Agent 20.0.0-8137 (20 LTS Update 2023-10-26) or later for Red Hat Enterprise Linux 9.

  21. 

    Requires Deep Security Agent 20.0.0-8438 (20 LTS Update 2023-12-12) or later.

  22. 

    Requires Deep Security Agent 20.0.1-7380 (20 LTS Update 2024-04-24) or later.